import Foundation
let pattern = #"(?:Solution:)?\s*(?:\d+\. )?(.+?)(?=\n(?:Solution:|\d+\. )|\Z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Solution: To create a Nextflow configuration file, follow these steps:
1. Create a new file named `nextflow.config` in the project directory.
2. Declare the configuration options by using the `params` keyword followed by variable names and their default values. For example:
```
params {
inputDir = './input'
outputDir = './output'
numThreads = 4
}
```
3. You can also override the default values in the configuration file by specifying new values when running the pipeline. For example:
```
nextflow run my_pipeline.nf --inputDir /path/to/input --outputDir /path/to/output --numThreads 8
```
4. Save the file and use it in your pipeline by calling the parameter name with the `$` symbol. For example:
```
process myProcess {
input:
file fastq from "$inputDir/*_R{1,2}.fastq.gz"
output:
file("${outputDir}/${sampleName}_mapped.bam")
script:
"""
my_command --input $fastq --threads $numThreads --output ${outputDir}/${sampleName}_mapped.bam
"""
}
```
Next request.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)