#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:Solution:)?\s*(?:\d+\. )?(.+?)(?=\n(?:Solution:|\d+\. )|\Z)"
Local $sString = "Solution: To create a Nextflow configuration file, follow these steps:" & @CRLF & _
"" & @CRLF & _
"1. Create a new file named `nextflow.config` in the project directory." & @CRLF & _
"2. Declare the configuration options by using the `params` keyword followed by variable names and their default values. For example:" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"params {" & @CRLF & _
" inputDir = './input'" & @CRLF & _
" outputDir = './output'" & @CRLF & _
" numThreads = 4" & @CRLF & _
"}" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"3. You can also override the default values in the configuration file by specifying new values when running the pipeline. For example:" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"nextflow run my_pipeline.nf --inputDir /path/to/input --outputDir /path/to/output --numThreads 8" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"4. Save the file and use it in your pipeline by calling the parameter name with the `$` symbol. For example:" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"process myProcess {" & @CRLF & _
" input:" & @CRLF & _
" file fastq from "$inputDir/*_R{1,2}.fastq.gz"" & @CRLF & _
" output:" & @CRLF & _
" file("${outputDir}/${sampleName}_mapped.bam")" & @CRLF & _
" script:" & @CRLF & _
" """" & @CRLF & _
" my_command --input $fastq --threads $numThreads --output ${outputDir}/${sampleName}_mapped.bam" & @CRLF & _
" """" & @CRLF & _
"}" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"Next request."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")