re = /public\s+(.+):([^,]+),?/m
str = '
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
'
subst = '@prop\\n\\t\\tpublic $1:$2;\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result