use strict;
my $str = '
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
';
my $regex = qr/public\s+(.+):([^,]+),?/mup;
my $subst = '@prop\\n\\t\\tpublic $1:$2;\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";