import Foundation
let pattern = #"^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://regex101.com/r/fW0vZ2
https://regex101.com/r/mH1fN5
regex101.com/r/121fa5
www.regex101.com/r/mH1fN5
http://www.regex101.com/r/fW0vZ2
https://www.regex101.com/r/mH1fN5
http://www.regex101.com/r/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)