const regex = /^(ht{2}ps?:\/{2})?(w{3}.)?regex101\.com\/r\/\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(ht{2}ps?:\\\/{2})?(w{3}.)?regex101\\.com\\\/r\\\/\\w+$', 'gm')
const str = `http://regex101.com/r/fW0vZ2
https://regex101.com/r/mH1fN5
regex101.com/r/121fa5
www.regex101.com/r/mH1fN5
http://www.regex101.com/r/fW0vZ2
https://www.regex101.com/r/mH1fN5
http://www.regex101.com/r/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}