use strict;
my $str = 'test:T1
test:C
test:T0
test:T1
test_TTES_SJ:T1
:T1
:T1
test:C1
!#$%^&*:T0
a a:T1
';
my $regex = qr/^\w+:([Tt][0-9]|[Cc])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}