const regex = /^\w+:([Tt][0-9]|[Cc])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+:([Tt][0-9]|[Cc])$', 'gm')
const str = `test:T1
test:C
test:T0
test:T1
test_TTES_SJ:T1
:T1
:T1
test:C1
!#\$%^&*:T0
a a:T1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}