package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+W+)(..)`)
var str = `Масло моторное Bardahl XTS 0W20 синтетическое 5 л 36333
Масло моторное Bardahl XTS 0W20 синтетическое 1 л 36331
Масло моторное Bardahl XTS 0W30 синтетическое 5 л 36133
Масло моторное Bardahl XTS 0W40 синтетическое 5л 36143
Масло моторное Bardahl XTS 0W40 синтетическое 1 л 36141
Масло моторное Bardahl XTC C60 0W40 синтетическое 1 л 300040
Масло моторное Bardahl XTC 10W40 полусинтетическое 5 л 36243
Масло моторное Bardahl XTC 10W40 полусинтетическое 1 л 36241
`
var substitution = "\1-\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}