#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+W+)(..)"
Local $sString = "Масло моторное Bardahl XTS 0W20 синтетическое 5 л 36333" & @CRLF & _
"Масло моторное Bardahl XTS 0W20 синтетическое 1 л 36331" & @CRLF & _
"Масло моторное Bardahl XTS 0W30 синтетическое 5 л 36133" & @CRLF & _
"Масло моторное Bardahl XTS 0W40 синтетическое 5л 36143" & @CRLF & _
"Масло моторное Bardahl XTS 0W40 синтетическое 1 л 36141" & @CRLF & _
"Масло моторное Bardahl XTC C60 0W40 синтетическое 1 л 300040" & @CRLF & _
"Масло моторное Bardahl XTC 10W40 полусинтетическое 5 л 36243" & @CRLF & _
"Масло моторное Bardahl XTC 10W40 полусинтетическое 1 л 36241" & @CRLF & _
""
Local $sSubst = "\1-\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)