re = /^\s*(.+)\s*(=(\s*(['`"]?)(.*)\2\s*$))?/m
str = 'woop=123
wap
wep= salutations'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end