$re = '/^\s*(.+)\s*(=(\s*([\'`"]?)(.*)\2\s*$))?/m';
$str = 'woop=123
wap
wep= salutations';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);