// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d[ -]*?){9}").unwrap();
let string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer euismod blandit efficitur. Cras velit mi, vehicula eget velit sit amet, tempor condimentum magna. Aenean ut libero luctus, elementum nulla quis, bibendum erat. Vestibulum rutrum sit amet leo et scelerisque. Phasellus at elit cursu001-00-1234s, ullamcorper enim consequat, finibus augue. Donec fringilla nisi quis aliquam hendrerit. Mauris quis gravida lectus. Aenean blandit porttitor libero tempor commodo. Duis interdum congue mollis. Etiam eget scelerisque metus, a posuere orci. Nam ac eros eu lectus tincidunt viverra. In quis tellus viverra, venenatis eros ac, lacinia justo. Nulla facilisi. Nunc dignissim urna non eros varius iaculis. Vestibulum magna justo, maximus eu nulla nec, interdum facilisis diam. Praesent justo enim, consequat eget interdum ac, placerat laoreet est.
Quisque sapien nisi, aliquet a cursus congue, faucibus id urna. Morbi vestibulum arcu non magna rutrum malesuada. Ut aliquam lacus in nulla 001001234 molestie hendrerit. Donec hendrerit sodales dignissim. Sed ac libero ullamcorper, pulvinar lorem id, sodales odio. Cras urna urna, molestie a risus sit amet, tincidunt bibendum lacus. Nullam in aliquet dui. Aenean suscipit vehicula commodo.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}