use strict;
my $str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer euismod blandit efficitur. Cras velit mi, vehicula eget velit sit amet, tempor condimentum magna. Aenean ut libero luctus, elementum nulla quis, bibendum erat. Vestibulum rutrum sit amet leo et scelerisque. Phasellus at elit cursu001-00-1234s, ullamcorper enim consequat, finibus augue. Donec fringilla nisi quis aliquam hendrerit. Mauris quis gravida lectus. Aenean blandit porttitor libero tempor commodo. Duis interdum congue mollis. Etiam eget scelerisque metus, a posuere orci. Nam ac eros eu lectus tincidunt viverra. In quis tellus viverra, venenatis eros ac, lacinia justo. Nulla facilisi. Nunc dignissim urna non eros varius iaculis. Vestibulum magna justo, maximus eu nulla nec, interdum facilisis diam. Praesent justo enim, consequat eget interdum ac, placerat laoreet est.
Quisque sapien nisi, aliquet a cursus congue, faucibus id urna. Morbi vestibulum arcu non magna rutrum malesuada. Ut aliquam lacus in nulla 001001234 molestie hendrerit. Donec hendrerit sodales dignissim. Sed ac libero ullamcorper, pulvinar lorem id, sodales odio. Cras urna urna, molestie a risus sit amet, tincidunt bibendum lacus. Nullam in aliquet dui. Aenean suscipit vehicula commodo.';
my $regex = qr/(?:\d[ -]*?){9}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}