import Foundation
let pattern = #"\x19A(\d*)d\[?(\d*)?\]?(.*)-(\S+)\s(\d+)\x0C?(.*)?\x18|\x19A(\d*)d(\S*)\s?(\d*)\:?(.*)\x18|RECV,4,(\d*),\[?(\d*)?\]?(.*)-(\S+)\s(\d+)\%?0?C?(.*)?|RECV,4,(\d*),(\S*)\s?(\d*)\:?(.*)\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A0707288dMessage
A0707288dMessage 1
A0707288dMessage 1:Cancel 1
A0707288dMessage-Location. 3
A0707288dMessage-Location. 3:Cancel 3
A0707288dMessage-Location. 3V1
A0707288dMessage-Location. 3:Cancel 3V1
A0707288d[00]Message-Location. 3
A0707288d[00]Message-Location. 3:Cancel 3
A0707288d[00]Message-Location. 3V1
A0707288d[00]Message-Location. 3:Cancel 3V1
RECV,4,0707288,Message
RECV,4,0707288,Message 1
RECV,4,0707288,Message 1:Cancel 1
RECV,4,0707288,Message-Location. 3
RECV,4,0707288,Message-Location. 3:Cancel 3
RECV,4,0707288,Message-Location. 3%0CV1
RECV,4,0707288,Message-Location. 3:Cancel 3%0CV1
RECV,4,0707288,[00]Message-Location. 3
RECV,4,0707288,[00]Message-Location. 3:Cancel 3
RECV,4,0707288,[00]Message-Location. 3%0CV1
RECV,4,0707288,[00]Message-Location. 3:Cancel 3%0CV1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)