// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\x19A(\d*)d\[?(\d*)?\]?(.*)-(\S+)\s(\d+)\x0C?(.*)?\x18|\x19A(\d*)d(\S*)\s?(\d*)\:?(.*)\x18|RECV,4,(\d*),\[?(\d*)?\]?(.*)-(\S+)\s(\d+)\%?0?C?(.*)?|RECV,4,(\d*),(\S*)\s?(\d*)\:?(.*)\s").unwrap();
let string = "A0707288dMessage
A0707288dMessage 1
A0707288dMessage 1:Cancel 1
A0707288dMessage-Location. 3
A0707288dMessage-Location. 3:Cancel 3
A0707288dMessage-Location. 3V1
A0707288dMessage-Location. 3:Cancel 3V1
A0707288d[00]Message-Location. 3
A0707288d[00]Message-Location. 3:Cancel 3
A0707288d[00]Message-Location. 3V1
A0707288d[00]Message-Location. 3:Cancel 3V1
RECV,4,0707288,Message
RECV,4,0707288,Message 1
RECV,4,0707288,Message 1:Cancel 1
RECV,4,0707288,Message-Location. 3
RECV,4,0707288,Message-Location. 3:Cancel 3
RECV,4,0707288,Message-Location. 3%0CV1
RECV,4,0707288,Message-Location. 3:Cancel 3%0CV1
RECV,4,0707288,[00]Message-Location. 3
RECV,4,0707288,[00]Message-Location. 3:Cancel 3
RECV,4,0707288,[00]Message-Location. 3%0CV1
RECV,4,0707288,[00]Message-Location. 3:Cancel 3%0CV1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}