re = /(?m){\S+}/m
str = ':name-of-an-attribute:
:name-of-an-attribute: value of the attribute
:url-org: https://example.org/projects
:url-project: {url-org}/project-name
https://docs.asciidoctor.org/asciidoc/latest/attributes/attribute-entries/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end