import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)\\{\\S+\\}";
final String string = ":name-of-an-attribute:\n"
+ ":name-of-an-attribute: value of the attribute\n"
+ ":url-org: https://example.org/projects\n"
+ ":url-project: {url-org}/project-name\n\n\n\n"
+ "https://docs.asciidoctor.org/asciidoc/latest/attributes/attribute-entries/\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}