re = /^(ldap(s)?:\/\/)(((\d{1,3}.){3}\d{1,3}(:\d+)?)|(\w|\d|)+|((\[([a-f0-9]{1,4}:{1,2}){1,4}([a-f0-9]{1,4})\])(:\d+)?)).\w+$/m
str = 'ldap://127.0.0.1:389
ldap://127.0.0.1
ldap://mydomain.test
ldaps://[fe80:4049:92ff:fe44:4bd1]:5060
ldap://[fe80::4bd1]:5060'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end