import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(ldap(s)?:\\/\\/)(((\\d{1,3}.){3}\\d{1,3}(:\\d+)?)|(\\w|\\d|)+|((\\[([a-f0-9]{1,4}:{1,2}){1,4}([a-f0-9]{1,4})\\])(:\\d+)?)).\\w+$";
final String string = "ldap://127.0.0.1:389\n"
+ "ldap://127.0.0.1\n"
+ "ldap://mydomain.test\n"
+ "ldaps://[fe80:4049:92ff:fe44:4bd1]:5060\n"
+ "ldap://[fe80::4bd1]:5060";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}