use strict;
my $str = 'Регулярные выражения представляют собой похожий, но гораздо более сильный инструмент
для поиска строк, проверки их на соответствие какому-либо шаблону и другой подобной
работы. Англоязычное название этого инструмента — Regular Expressions или просто RegExp.
Строго говоря, регулярные выражения — специальный язык для описания шаблонов строк.
АААА аааа АаАаАаАа 123 123 12345 11223344
А1Б2В3 АА11 ББ22ВВ 33ГГ44
Тест! Ещё! Даёшь! ЁЁЁёёё
QwertyЙцукен
+-,/[](), *** (***), a*(b+[c+d])*e/f+g-h
!!"""####$$$$$%%%%%&&&\'\'\'(((())***++++,,,,,-----..//:::;;;;<<<<<===>>>????
@@@@@[[[[\\\\\\]]]]]^^^__`````{{{{|||||}}}}}~~~~~
<a href="#10">10: CamelCase -> under_score</a>;
<a href="#11">11: Удаление повторов</a>;
<a href="#12">12: Близкие слова</a>;
<a href="#13">13: Форматирование больших чисел</a>;
<a href="#14">14: Разделить текст на предложения</a>;
<a href="#15">15: Форматирование номера телефона</a>;
<a href="#16">16: Поиск e-mail\'ов — 2</a>;';
my $regex = qr/[Aa]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}