#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[Aa]"
Local $sString = "Регулярные выражения представляют собой похожий, но гораздо более сильный инструмент " & @CRLF & _
"для поиска строк, проверки их на соответствие какому-либо шаблону и другой подобной " & @CRLF & _
"работы. Англоязычное название этого инструмента — Regular Expressions или просто RegExp. " & @CRLF & _
"Строго говоря, регулярные выражения — специальный язык для описания шаблонов строк." & @CRLF & _
"" & @CRLF & _
"АААА аааа АаАаАаАа 123 123 12345 11223344" & @CRLF & _
"А1Б2В3 АА11 ББ22ВВ 33ГГ44" & @CRLF & _
"" & @CRLF & _
"Тест! Ещё! Даёшь! ЁЁЁёёё" & @CRLF & _
"" & @CRLF & _
"QwertyЙцукен" & @CRLF & _
"" & @CRLF & _
"+-,/[](), *** (***), a*(b+[c+d])*e/f+g-h" & @CRLF & _
"" & @CRLF & _
"!!"""####$$$$$%%%%%&&&'''(((())***++++,,,,,-----..//:::;;;;<<<<<===>>>????" & @CRLF & _
"@@@@@[[[[\\\]]]]]^^^__`````{{{{|||||}}}}}~~~~~" & @CRLF & _
"" & @CRLF & _
"<a href="#10">10: CamelCase -> under_score</a>;" & @CRLF & _
"<a href="#11">11: Удаление повторов</a>;" & @CRLF & _
"<a href="#12">12: Близкие слова</a>;" & @CRLF & _
"<a href="#13">13: Форматирование больших чисел</a>;" & @CRLF & _
"<a href="#14">14: Разделить текст на предложения</a>;" & @CRLF & _
"<a href="#15">15: Форматирование номера телефона</a>;" & @CRLF & _
"<a href="#16">16: Поиск e-mail'ов — 2</a>;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")