re = /^\d*(0)1[23456789] | (0|1)2[3456789] | (0|1|2)3[456789] |(0|1|2|3)4[56789] | (0|1|2|3|4)5[6789] | (0|1|2|3|4|5)6[789] |(0|1|2|3|4|5|6)7[89] | (0|1|2|3|4|5|6|7)8(9)\d*$/mx
str = '123
9876456000
123456789
246
91370
3456
111
415263
xyz123xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end