import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d*(0)1[23456789] | (0|1)2[3456789] | (0|1|2)3[456789] |(0|1|2|3)4[56789] | (0|1|2|3|4)5[6789] | (0|1|2|3|4|5)6[789] |(0|1|2|3|4|5|6)7[89] | (0|1|2|3|4|5|6|7)8(9)\\d*$";
final String string = "123\n"
+ "9876456000\n"
+ "123456789\n"
+ "246\n"
+ "91370\n"
+ "3456\n\n"
+ "111\n"
+ "415263\n"
+ "xyz123xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}