re = /([\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}):([\d]{1,5})/m
str = '123.51.5.122:800'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end