package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}\.[\d]{1,3}):([\d]{1,5})`)
var str = `123.51.5.122:800`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}