use strict;
my $str = 'HOLY CRAP - THIS LOOKS PERFECT FOR ISO + YYYY-MM-DD!
2015-08-10
2015-10-08
12015-08-10
-2015-08-10
+2015-08-10
0015-08-10
1582-10-10
2015-02-28
2016-02-29
2000-02-29
0000-02-29
-2000-02-29
-2016-02-29
200000-02-29
2016-366
2000-366
0000-366
-2016-366
-2000-366
2015-081
2015-W33-1
2015-W53-7
2015-08-10
2016-11-09T01:00:23Z
2083-06-12T02:49:23.473Z
2020-06-12T02:49:23.473Z
2083-06-12T02:49:23
2020-06-12T02:49:23Z
2000-01-01
2000-01-99
12/01/1986
02/29/2016
02/29/2015
13/31/1986
12/31/1980
1/32/2015
1/31/2015
01012016
01/01/2016
1/1/2016
1/1/16
01/01/16
01-01-2016
1-1-2016
1-1-16
01-01-16
';
my $regex = qr/^(\d{4}|\+\d{6})(?:-(\d{2})(?:-(\d{2})(?:T(\d{2}):(\d{2}):(\d{2})(?:\.{0,1})(\d{0,})(Z|([\-+])(\d{2})(?::{0,1})(\d{2}))?)?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}