import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{4}|\\+\\d{6})(?:-(\\d{2})(?:-(\\d{2})(?:T(\\d{2}):(\\d{2}):(\\d{2})(?:\\.{0,1})(\\d{0,})(Z|([\\-+])(\\d{2})(?::{0,1})(\\d{2}))?)?)?)?$";
final String string = "HOLY CRAP - THIS LOOKS PERFECT FOR ISO + YYYY-MM-DD!\n\n"
+ "2015-08-10\n"
+ "2015-10-08\n"
+ "12015-08-10\n"
+ "-2015-08-10\n"
+ "+2015-08-10\n"
+ "0015-08-10\n"
+ "1582-10-10\n"
+ "2015-02-28\n"
+ "2016-02-29\n"
+ "2000-02-29\n"
+ "0000-02-29\n"
+ "-2000-02-29\n"
+ "-2016-02-29\n"
+ "200000-02-29\n"
+ "2016-366\n"
+ "2000-366\n"
+ "0000-366\n"
+ "-2016-366\n"
+ "-2000-366\n"
+ "2015-081\n"
+ "2015-W33-1\n"
+ "2015-W53-7\n"
+ " 2015-08-10 \n\n"
+ "2016-11-09T01:00:23Z\n"
+ "2083-06-12T02:49:23.473Z\n"
+ "2020-06-12T02:49:23.473Z\n"
+ "2083-06-12T02:49:23\n"
+ "2020-06-12T02:49:23Z\n"
+ "2000-01-01\n"
+ "2000-01-99\n"
+ "12/01/1986\n"
+ "02/29/2016\n"
+ "02/29/2015\n"
+ "13/31/1986\n"
+ "12/31/1980\n"
+ "1/32/2015\n"
+ "1/31/2015\n\n\n"
+ "01012016\n"
+ "01/01/2016\n"
+ "1/1/2016\n"
+ "1/1/16\n"
+ "01/01/16\n"
+ "01-01-2016\n"
+ "1-1-2016\n"
+ "1-1-16\n"
+ "01-01-16\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}