import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Duration:\\s{1}(\\d+?):(\\d+?):(\\d+\\.\\d+?),";
final String string = " Metadata:\n"
+ " major_brand : isom\n"
+ " minor_version : 0\n"
+ " compatible_brands: mp41avc1\n"
+ " creation_time : 2017-02-01T11:29:03.000000Z\n"
+ " playback_requirements: QuickTime 6.0 or greater\n"
+ " playback_requirements-eng: QuickTime 6.0 or greater\n"
+ " encoder : vlc 2.2.4 stream output\n"
+ " encoder-eng : vlc 2.2.4 stream output\n"
+ " Duration: 00:00:12.52, start: 0.000000, bitrate: 3597 kb/s\n"
+ " Stream #0:0(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 3475 kb/s, 21.57 fps, 23.98 tbr, 1000k tbn, 47.95 tbc (default)\n"
+ " Metadata:\n"
+ " creation_time : 2017-02-01T11:29:03.000000Z\n"
+ " handler_name : VideoHandler\n"
+ " Stream #0:1(jpn): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 128 kb/s (default)\n"
+ " Metadata:\n"
+ " creation_time : 2017-02-01T11:29:03.000000Z\n"
+ " handler_name : SoundHandler";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}