# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Duration:\s{1}(\d+?):(\d+?):(\d+\.\d+?),"
test_str = (" Metadata:\n"
" major_brand : isom\n"
" minor_version : 0\n"
" compatible_brands: mp41avc1\n"
" creation_time : 2017-02-01T11:29:03.000000Z\n"
" playback_requirements: QuickTime 6.0 or greater\n"
" playback_requirements-eng: QuickTime 6.0 or greater\n"
" encoder : vlc 2.2.4 stream output\n"
" encoder-eng : vlc 2.2.4 stream output\n"
" Duration: 00:00:12.52, start: 0.000000, bitrate: 3597 kb/s\n"
" Stream #0:0(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 3475 kb/s, 21.57 fps, 23.98 tbr, 1000k tbn, 47.95 tbc (default)\n"
" Metadata:\n"
" creation_time : 2017-02-01T11:29:03.000000Z\n"
" handler_name : VideoHandler\n"
" Stream #0:1(jpn): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 128 kb/s (default)\n"
" Metadata:\n"
" creation_time : 2017-02-01T11:29:03.000000Z\n"
" handler_name : SoundHandler")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.