$re = '`(?P<indent>\s*)(?P<type>[\w]+)\s(?P<identifier>[\w\d]+)\s*=\s*`';
$str = ' int derp_errino = "derpieer."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);