package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<indent>\s*)(?P<type>[\w]+)\s(?P<identifier>[\w\d]+)\s*=\s*`)
var str = ` int derp_errino = "derpieer."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}