package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+):\s*(\w*)`)
var str = `raz: 2323212 dva:32234232 tri: 234232432 chetire:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}