re = /\\(?:.(?!\\))+$/mi
str = 'C:\\\\Projects\\\\Ensure_Solution\\\\Assistance\\\\App_WebReferences\\\\Web_ERP_WebService\\\\Web_ERP_Assistant.wsdl
C:\\\\Projects\\\\Ensure_Solution\\\\GD_EServices_Web\\\\App_WebReferences\\\\GD_Eservices_Web_Service\\\\GD_Eservices_Web_Service.wsdl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end