const regex = /\\(?:.(?!\\))+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\(?:.(?!\\\\))+$', 'gmi')
const str = `C:\\\\Projects\\\\Ensure_Solution\\\\Assistance\\\\App_WebReferences\\\\Web_ERP_WebService\\\\Web_ERP_Assistant.wsdl
C:\\\\Projects\\\\Ensure_Solution\\\\GD_EServices_Web\\\\App_WebReferences\\\\GD_Eservices_Web_Service\\\\GD_Eservices_Web_Service.wsdl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}