import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[2-9]([0-8])(?!\\1)\\d-?[2-9](?!1(?=1))\\d\\d-?\\d{4}";
final String string = "9055551212\n"
+ "905-5551212\n"
+ "905-555-1212\n"
+ "905 555 1212";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}