re = /(\d(?!\d)|[xyz)])(?=[\w(])/m
str = '888+(x+x)(xyz)+5(x+5)+5x5+5.5555+55x+x555cos(5x)+5sin(zx5)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end