const regex = /(\d(?!\d)|[xyz)])(?=[\w(])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d(?!\\d)|[xyz)])(?=[\\w(])', 'gm')
const str = `888+(x+x)(xyz)+5(x+5)+5x5+5.5555+55x+x555cos(5x)+5sin(zx5)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}