import Foundation
let pattern = #"((^[\w \']+)\:\n\n(^[\w. \-]+)\,\scon\s([\w.\-]+)\s[\w. \-]+\,\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+(\.|\s[\w. \-\,]+))|((^[\w ]+)\,\scon\s([\w.\-]+)\s[\w.\-]+\,\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+(\.|\s[\w. \-\,]+)\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Primera Región de Tarapacá:
Iquique, con siete jueces, con competencia sobre la misma comuna.
Segunda Región de Antofagasta:
Tocopilla, con un juez, con competencia sobre la misma comuna.
Calama, con cuatro jueces, con competencia sobre las comunas de Calama, Ollagüe y San Pedro de Atacama.
Antofagasta, con siete jueces, con competencia sobre las comunas de Sierra Gorda y Antofagasta.
Tercera Región de Atacama:
Diego de Almagro, con un juez, con competencia en la misma comuna.
Copiapó, con cuatro jueces, con competencia sobre las comunas de Copiapó y Tierra Amarilla.
Vallenar, con dos jueces, con competencia sobre las comunas de Vallenar y Alto del Carmen.
Cuarta Región de Coquimbo:
La Serena, con tres jueces, con competencia sobre las comunas de La Serena y La Higuera.
Vicuña, con un juez, con competencia sobre las comunas de Vicuña y Paihuano.
Coquimbo, con tres jueces, con competencia sobre la misma comuna.
Ovalle, con dos jueces, con competencia sobre las comunas de Ovalle, Río Hurtado, Punitaqui y Monte Patria.
Illapel, con un juez, con competencia sobre las comunas de Illapel y Salamanca.
Quinta Región de Valparaíso:
La Ligua, con un juez, con competencia sobre las comunas de La Ligua, Cabildo, Papudo y Zapallar.
Calera, con dos jueces, con competencia sobre las comunas de Nogales, Calera, La Cruz e Hijuelas.
San Felipe, con tres jueces, con competencia sobre las comunas de San Felipe, Catemu, Santa María, Panquehue y Llay-LLay.
Los Andes, con dos jueces, con competencia sobre las comunas de San Esteban, Rinconada, Calle Larga y Los Andes.
Quillota, con dos jueces, con competencia sobre la misma comuna.
Limache, con un juez, con competencia sobre las comunas de Limache y Olmué.
Viña del Mar, con ocho jueces, con competencia sobre las comunas de Viña del Mar y Concón.
Valparaíso, con nueve jueces, con competencia sobre las comunas de Valparaíso y Juan Fernández.
Quilpué, con tres jueces, con competencia sobre la misma comuna.
Villa Alemana, con dos jueces, con competencia sobre la misma comuna.
Casablanca, con un juez, con competencia sobre la misma comuna.
San Antonio, con cuatro jueces, con competencia sobre las comunas de Algarrobo, El Quisco, El Tabo, Cartagena, San Antonio y Santo Domingo.
Sexta Región del Libertador General Bernardo O'Higgins:
Graneros, con dos jueces, con competencia sobre las comunas de Mostazal, Graneros y Codegua.
Rancagua, con siete jueces, con competencia sobre las comunas de Rancagua, Machalí, Doñihue, Coínco y Olivar.
San Vicente, con dos jueces, con competencia sobre las comunas de Coltauco, Pichidegua y San Vicente.
Rengo, con dos jueces, con competencia sobre las comunas de Requínoa, Quinta de Tilcoco, Malloa y Rengo.
San Fernando, con tres jueces, con competencia sobre las comunas de San Fernando, Placilla y Chimbarongo.
Santa Cruz, con dos jueces, con competencia sobre las comunas de Santa Cruz, Nancagua, Lolol y Chépica.
Séptima Región del Maule:
Curicó, con cuatro jueces, con competencia sobre las comunas de Teno, Rauco, Curicó, Romeral y Sagrada Familia.
Molina, con un juez, con competencia sobre la misma comuna.
Constitución, con dos jueces, con competencia sobre las comunas de Constitución y Empedrado.
Talca, con seis jueces, con competencia sobre las comunas de Río Claro, Pencahue, Talca, Pelarco, San Clemente, Maule y San Rafael.
San Javier, con un juez, con competencia sobre las comunas de San Javier y Villa Alegre.
Cauquenes, con un juez, con competencia sobre la misma comuna.
Linares, con tres jueces, con competencia sobre las comunas de Colbún, Yerbas Buenas, Linares y Longaví.
Parral, con un juez, con competencia sobre las comunas de Parral y Retiro.
Octava Región del Bío Bío:
Tomé, con un juez, con competencia sobre la misma comuna.
Talcahuano, con cuatro jueces, con competencia sobre las comunas de Talcahuano y Hualpén.
Concepción, con siete jueces, con competencia sobre las comunas de Penco y Concepción.
San Pedro de la Paz, con tres jueces, con competencia sobre la misma comuna.
Chiguayante, con dos jueces, con competencia sobre las comunas de Chiguayante y Hualqui.
Coronel, con dos jueces, con competencia sobre la misma comuna.
Los Angeles, con cuatro jueces, con competencia sobre las comunas de Los Angeles, Quilleco y Antuco.
Arauco, con un juez, con competencia sobre la misma comuna.
Cañete, con un juez, con competencia sobre las comunas de Cañete, Contulmo y Tirúa.
Novena Región de La Araucanía:
Angol, con dos jueces, con competencia sobre las comunas de Angol y Renaico.
Victoria, con un juez, con competencia sobre la misma comuna.
Nueva Imperial, con un juez, con competencia sobre las comunas de Nueva Imperial, Cholchol y Teodoro Schmidt.
Temuco, con seis jueces, con competencia sobre las comunas de Temuco, Vilcún, Melipeuco, Cunco y Padre Las Casas.
Lautaro, con un juez, con competencia sobre las comunas de Galvarino, Perquenco y Lautaro.
Pitrufquén, con dos jueces, con competencia sobre las comunas de Freire, Pitrufquén y Gorbea.
Loncoche, con un juez, con competencia sobre la misma comuna.
Villarrica, con dos jueces, con competencia sobre la misma comuna.
Décima Región de Los Lagos:
Osorno, con cuatro jueces, con competencia sobre las comunas de San Juan de la Costa, San Pablo, Osorno y Puyehue.
Río Negro, con un juez, con competencia sobre las comunas de Río Negro, Puerto Octay y Purranque.
Puerto Varas, con dos jueces, con competencia sobre las comunas de Fresia, Frutillar, Puerto Varas y Llanquihue.
Puerto Montt, con seis jueces, con competencia sobre las comunas de Puerto Montt y Cochamó.
Ancud, con un juez, con competencia sobre las comunas de Ancud y Quemchi.
Castro, con dos jueces, con competencia sobre las comunas de Dalcahue, Castro, Chonchi, Puqueldón y Queilén.
Undécima Región de Aisén del General Carlos Ibáñez del Campo:
Coihaique, con dos jueces, con competencia sobre las comunas de Coihaique y Río Ibáñez.
Duodécima Región de Magallanes y la Antártica Chilena:
Punta Arenas, con cuatro jueces, con competencia sobre las comunas de Laguna Blanca, San Gregorio, Río Verde y Punta Arenas.
Decimocuarta Región de los Ríos:
Mariquina, con un juez, con competencia sobre las comunas de Mariquina y Lanco.
Valdivia, con tres jueces, con competencia sobre las comunas de Valdivia y Corral.
Los Lagos, con un juez, con competencia sobre las comunas de Máfil, Los Lagos y Futrono.
Decimoquinta Región de Arica y Parinacota:
Arica, con cinco jueces, con competencia sobre las comunas de General Lagos, Putre, Arica y Camarones.
Región Metropolitana de Santiago:
Colina, con cuatro jueces, con competencia sobre las comunas de Til Til, Colina y Lampa.
Puente Alto, con ocho jueces, con competencia sobre las comunas de Puente Alto, San José de Maipo y Pirque.
San Bernardo, con diez jueces, con competencia sobre las comunas de San Bernardo, Calera de Tango, Buin y Paine.
Melipilla, con tres jueces, con competencia sobre las comunas de Melipilla, San Pedro y Alhué.
Talagante, con seis jueces, con competencia sobre las comunas de Talagante, El Monte, Isla de Maipo, Peñaflor y Padre Hurtado.
Curacaví, con dos jueces, con competencia sobre las comunas de Curacaví y María Pinto.
Primer Juzgado de Garantía de Santiago, con cinco jueces, con competencia sobre la comuna de Pudahuel.
Segundo Juzgado de Garantía de Santiago, con diez jueces, con competencia sobre las comunas de Quilicura, Huechuraba, Renca y Conchalí.
Tercer Juzgado de Garantía de Santiago, con seis jueces, con competencia sobre las comunas de Independencia y Recoleta.
Cuarto Juzgado de Garantía de Santiago, con doce jueces, con competencia sobre las comunas de Lo Barnechea, Vitacura, Las Condes y La Reina.
Quinto Juzgado de Garantía de Santiago, con cinco jueces, con competencia sobre las comunas de Cerro Navia y Lo Prado.
Sexto Juzgado de Garantía de Santiago, con siete jueces, con competencia sobre las comunas de Estación Central y Quinta Normal.
Séptimo Juzgado de Garantía de Santiago, con doce jueces, con competencia sobre la comuna de Santiago.
Octavo Juzgado de Garantía de Santiago, con nueve jueces, con competencia sobre las comunas de Providencia y Ñuñoa.
Noveno Juzgado de Garantía de Santiago, con nueve jueces, con competencia sobre las comunas de Maipú y Cerrillos.
Décimo Juzgado de Garantía de Santiago, con cinco jueces, con competencia sobre las comunas de Lo Espejo y Pedro Aguirre Cerda.
Undécimo Juzgado de Garantía de Santiago, con ocho jueces, con competencia sobre las comunas de San Miguel, La Cisterna y El Bosque.
Duodécimo Juzgado de Garantía de Santiago, con seis jueces, con competencia sobre las comunas de San Joaquín y La Granja.
Decimotercer Juzgado de Garantía de Santiago, con siete jueces, con competencia sobre las comunas de Macul y Peñalolén.
Decimocuarto Juzgado de Garantía de Santiago, con nueve jueces, con competencia sobre la comuna de La Florida.
Decimoquinto Juzgado de Garantía de Santiago, con siete jueces, con competencia sobre las comunas de San Ramón y La Pintana.
Región de Ñuble:
San Carlos, con dos jueces, con competencia sobre las comunas de San Carlos, Ñiquén y San Fabián.
Chillán, con cuatro jueces, con competencia sobre las comunas de San Nicolás, Chillán, Coihueco, Pinto y Chillán Viejo.
Yungay, con un juez, con competencia sobre las comunas de El Carmen, Pemuco, Yungay y Tucapel.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)