#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^[\w \']+)\:\n\n(^[\w. \-]+)\,\scon\s([\w.\-]+)\s[\w. \-]+\,\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+(\.|\s[\w. \-\,]+))|((^[\w ]+)\,\scon\s([\w.\-]+)\s[\w.\-]+\,\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+\s[\w.\-]+(\.|\s[\w. \-\,]+)\.)"
Local $sString = "Primera Región de Tarapacá:" & @CRLF & _
"" & @CRLF & _
"Iquique, con siete jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Segunda Región de Antofagasta:" & @CRLF & _
"" & @CRLF & _
"Tocopilla, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Calama, con cuatro jueces, con competencia sobre las comunas de Calama, Ollagüe y San Pedro de Atacama." & @CRLF & _
"" & @CRLF & _
"Antofagasta, con siete jueces, con competencia sobre las comunas de Sierra Gorda y Antofagasta." & @CRLF & _
"" & @CRLF & _
"Tercera Región de Atacama:" & @CRLF & _
"" & @CRLF & _
"Diego de Almagro, con un juez, con competencia en la misma comuna." & @CRLF & _
"" & @CRLF & _
"Copiapó, con cuatro jueces, con competencia sobre las comunas de Copiapó y Tierra Amarilla." & @CRLF & _
"" & @CRLF & _
"Vallenar, con dos jueces, con competencia sobre las comunas de Vallenar y Alto del Carmen." & @CRLF & _
"" & @CRLF & _
"Cuarta Región de Coquimbo:" & @CRLF & _
"" & @CRLF & _
"La Serena, con tres jueces, con competencia sobre las comunas de La Serena y La Higuera." & @CRLF & _
"" & @CRLF & _
"Vicuña, con un juez, con competencia sobre las comunas de Vicuña y Paihuano." & @CRLF & _
"" & @CRLF & _
"Coquimbo, con tres jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Ovalle, con dos jueces, con competencia sobre las comunas de Ovalle, Río Hurtado, Punitaqui y Monte Patria." & @CRLF & _
"" & @CRLF & _
"Illapel, con un juez, con competencia sobre las comunas de Illapel y Salamanca." & @CRLF & _
"" & @CRLF & _
"Quinta Región de Valparaíso:" & @CRLF & _
"" & @CRLF & _
"La Ligua, con un juez, con competencia sobre las comunas de La Ligua, Cabildo, Papudo y Zapallar." & @CRLF & _
"" & @CRLF & _
"Calera, con dos jueces, con competencia sobre las comunas de Nogales, Calera, La Cruz e Hijuelas." & @CRLF & _
"" & @CRLF & _
"San Felipe, con tres jueces, con competencia sobre las comunas de San Felipe, Catemu, Santa María, Panquehue y Llay-LLay." & @CRLF & _
"" & @CRLF & _
"Los Andes, con dos jueces, con competencia sobre las comunas de San Esteban, Rinconada, Calle Larga y Los Andes." & @CRLF & _
"" & @CRLF & _
"Quillota, con dos jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Limache, con un juez, con competencia sobre las comunas de Limache y Olmué." & @CRLF & _
"" & @CRLF & _
"Viña del Mar, con ocho jueces, con competencia sobre las comunas de Viña del Mar y Concón." & @CRLF & _
"" & @CRLF & _
"Valparaíso, con nueve jueces, con competencia sobre las comunas de Valparaíso y Juan Fernández." & @CRLF & _
"" & @CRLF & _
"Quilpué, con tres jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Villa Alemana, con dos jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Casablanca, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"San Antonio, con cuatro jueces, con competencia sobre las comunas de Algarrobo, El Quisco, El Tabo, Cartagena, San Antonio y Santo Domingo." & @CRLF & _
"" & @CRLF & _
"Sexta Región del Libertador General Bernardo O'Higgins:" & @CRLF & _
"" & @CRLF & _
"Graneros, con dos jueces, con competencia sobre las comunas de Mostazal, Graneros y Codegua." & @CRLF & _
"" & @CRLF & _
"Rancagua, con siete jueces, con competencia sobre las comunas de Rancagua, Machalí, Doñihue, Coínco y Olivar." & @CRLF & _
"" & @CRLF & _
"San Vicente, con dos jueces, con competencia sobre las comunas de Coltauco, Pichidegua y San Vicente." & @CRLF & _
"" & @CRLF & _
"Rengo, con dos jueces, con competencia sobre las comunas de Requínoa, Quinta de Tilcoco, Malloa y Rengo." & @CRLF & _
"" & @CRLF & _
"San Fernando, con tres jueces, con competencia sobre las comunas de San Fernando, Placilla y Chimbarongo." & @CRLF & _
"" & @CRLF & _
"Santa Cruz, con dos jueces, con competencia sobre las comunas de Santa Cruz, Nancagua, Lolol y Chépica." & @CRLF & _
"" & @CRLF & _
"Séptima Región del Maule:" & @CRLF & _
"" & @CRLF & _
"Curicó, con cuatro jueces, con competencia sobre las comunas de Teno, Rauco, Curicó, Romeral y Sagrada Familia." & @CRLF & _
"" & @CRLF & _
"Molina, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Constitución, con dos jueces, con competencia sobre las comunas de Constitución y Empedrado." & @CRLF & _
"" & @CRLF & _
"Talca, con seis jueces, con competencia sobre las comunas de Río Claro, Pencahue, Talca, Pelarco, San Clemente, Maule y San Rafael." & @CRLF & _
"" & @CRLF & _
"San Javier, con un juez, con competencia sobre las comunas de San Javier y Villa Alegre." & @CRLF & _
"" & @CRLF & _
"Cauquenes, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Linares, con tres jueces, con competencia sobre las comunas de Colbún, Yerbas Buenas, Linares y Longaví." & @CRLF & _
"" & @CRLF & _
"Parral, con un juez, con competencia sobre las comunas de Parral y Retiro." & @CRLF & _
"" & @CRLF & _
"Octava Región del Bío Bío:" & @CRLF & _
"" & @CRLF & _
"Tomé, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Talcahuano, con cuatro jueces, con competencia sobre las comunas de Talcahuano y Hualpén." & @CRLF & _
"" & @CRLF & _
"Concepción, con siete jueces, con competencia sobre las comunas de Penco y Concepción." & @CRLF & _
"" & @CRLF & _
"San Pedro de la Paz, con tres jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Chiguayante, con dos jueces, con competencia sobre las comunas de Chiguayante y Hualqui." & @CRLF & _
"" & @CRLF & _
"Coronel, con dos jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Los Angeles, con cuatro jueces, con competencia sobre las comunas de Los Angeles, Quilleco y Antuco." & @CRLF & _
"" & @CRLF & _
"Arauco, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Cañete, con un juez, con competencia sobre las comunas de Cañete, Contulmo y Tirúa." & @CRLF & _
"" & @CRLF & _
"Novena Región de La Araucanía:" & @CRLF & _
"" & @CRLF & _
"Angol, con dos jueces, con competencia sobre las comunas de Angol y Renaico." & @CRLF & _
"" & @CRLF & _
"Victoria, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Nueva Imperial, con un juez, con competencia sobre las comunas de Nueva Imperial, Cholchol y Teodoro Schmidt." & @CRLF & _
"" & @CRLF & _
"Temuco, con seis jueces, con competencia sobre las comunas de Temuco, Vilcún, Melipeuco, Cunco y Padre Las Casas." & @CRLF & _
"" & @CRLF & _
"Lautaro, con un juez, con competencia sobre las comunas de Galvarino, Perquenco y Lautaro." & @CRLF & _
"" & @CRLF & _
"Pitrufquén, con dos jueces, con competencia sobre las comunas de Freire, Pitrufquén y Gorbea." & @CRLF & _
"" & @CRLF & _
"Loncoche, con un juez, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Villarrica, con dos jueces, con competencia sobre la misma comuna." & @CRLF & _
"" & @CRLF & _
"Décima Región de Los Lagos:" & @CRLF & _
"" & @CRLF & _
"Osorno, con cuatro jueces, con competencia sobre las comunas de San Juan de la Costa, San Pablo, Osorno y Puyehue." & @CRLF & _
"" & @CRLF & _
"Río Negro, con un juez, con competencia sobre las comunas de Río Negro, Puerto Octay y Purranque." & @CRLF & _
"" & @CRLF & _
"Puerto Varas, con dos jueces, con competencia sobre las comunas de Fresia, Frutillar, Puerto Varas y Llanquihue." & @CRLF & _
"" & @CRLF & _
"Puerto Montt, con seis jueces, con competencia sobre las comunas de Puerto Montt y Cochamó." & @CRLF & _
"" & @CRLF & _
"Ancud, con un juez, con competencia sobre las comunas de Ancud y Quemchi." & @CRLF & _
"" & @CRLF & _
"Castro, con dos jueces, con competencia sobre las comunas de Dalcahue, Castro, Chonchi, Puqueldón y Queilén." & @CRLF & _
"" & @CRLF & _
"Undécima Región de Aisén del General Carlos Ibáñez del Campo:" & @CRLF & _
"" & @CRLF & _
"Coihaique, con dos jueces, con competencia sobre las comunas de Coihaique y Río Ibáñez." & @CRLF & _
"" & @CRLF & _
"Duodécima Región de Magallanes y la Antártica Chilena:" & @CRLF & _
"" & @CRLF & _
"Punta Arenas, con cuatro jueces, con competencia sobre las comunas de Laguna Blanca, San Gregorio, Río Verde y Punta Arenas." & @CRLF & _
"" & @CRLF & _
"Decimocuarta Región de los Ríos:" & @CRLF & _
"" & @CRLF & _
"Mariquina, con un juez, con competencia sobre las comunas de Mariquina y Lanco." & @CRLF & _
"" & @CRLF & _
"Valdivia, con tres jueces, con competencia sobre las comunas de Valdivia y Corral." & @CRLF & _
"" & @CRLF & _
"Los Lagos, con un juez, con competencia sobre las comunas de Máfil, Los Lagos y Futrono." & @CRLF & _
"" & @CRLF & _
"Decimoquinta Región de Arica y Parinacota:" & @CRLF & _
"" & @CRLF & _
"Arica, con cinco jueces, con competencia sobre las comunas de General Lagos, Putre, Arica y Camarones." & @CRLF & _
"" & @CRLF & _
"Región Metropolitana de Santiago:" & @CRLF & _
"" & @CRLF & _
"Colina, con cuatro jueces, con competencia sobre las comunas de Til Til, Colina y Lampa." & @CRLF & _
"" & @CRLF & _
"Puente Alto, con ocho jueces, con competencia sobre las comunas de Puente Alto, San José de Maipo y Pirque." & @CRLF & _
"" & @CRLF & _
"San Bernardo, con diez jueces, con competencia sobre las comunas de San Bernardo, Calera de Tango, Buin y Paine." & @CRLF & _
"" & @CRLF & _
"Melipilla, con tres jueces, con competencia sobre las comunas de Melipilla, San Pedro y Alhué." & @CRLF & _
"" & @CRLF & _
"Talagante, con seis jueces, con competencia sobre las comunas de Talagante, El Monte, Isla de Maipo, Peñaflor y Padre Hurtado." & @CRLF & _
"" & @CRLF & _
"Curacaví, con dos jueces, con competencia sobre las comunas de Curacaví y María Pinto." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Primer Juzgado de Garantía de Santiago, con cinco jueces, con competencia sobre la comuna de Pudahuel." & @CRLF & _
"" & @CRLF & _
"Segundo Juzgado de Garantía de Santiago, con diez jueces, con competencia sobre las comunas de Quilicura, Huechuraba, Renca y Conchalí." & @CRLF & _
"" & @CRLF & _
"Tercer Juzgado de Garantía de Santiago, con seis jueces, con competencia sobre las comunas de Independencia y Recoleta." & @CRLF & _
"" & @CRLF & _
"Cuarto Juzgado de Garantía de Santiago, con doce jueces, con competencia sobre las comunas de Lo Barnechea, Vitacura, Las Condes y La Reina." & @CRLF & _
"" & @CRLF & _
"Quinto Juzgado de Garantía de Santiago, con cinco jueces, con competencia sobre las comunas de Cerro Navia y Lo Prado." & @CRLF & _
"" & @CRLF & _
"Sexto Juzgado de Garantía de Santiago, con siete jueces, con competencia sobre las comunas de Estación Central y Quinta Normal." & @CRLF & _
"" & @CRLF & _
"Séptimo Juzgado de Garantía de Santiago, con doce jueces, con competencia sobre la comuna de Santiago." & @CRLF & _
"" & @CRLF & _
"Octavo Juzgado de Garantía de Santiago, con nueve jueces, con competencia sobre las comunas de Providencia y Ñuñoa." & @CRLF & _
"" & @CRLF & _
"Noveno Juzgado de Garantía de Santiago, con nueve jueces, con competencia sobre las comunas de Maipú y Cerrillos." & @CRLF & _
"" & @CRLF & _
"Décimo Juzgado de Garantía de Santiago, con cinco jueces, con competencia sobre las comunas de Lo Espejo y Pedro Aguirre Cerda." & @CRLF & _
"" & @CRLF & _
"Undécimo Juzgado de Garantía de Santiago, con ocho jueces, con competencia sobre las comunas de San Miguel, La Cisterna y El Bosque." & @CRLF & _
"" & @CRLF & _
"Duodécimo Juzgado de Garantía de Santiago, con seis jueces, con competencia sobre las comunas de San Joaquín y La Granja." & @CRLF & _
"" & @CRLF & _
"Decimotercer Juzgado de Garantía de Santiago, con siete jueces, con competencia sobre las comunas de Macul y Peñalolén." & @CRLF & _
"" & @CRLF & _
"Decimocuarto Juzgado de Garantía de Santiago, con nueve jueces, con competencia sobre la comuna de La Florida." & @CRLF & _
"" & @CRLF & _
"Decimoquinto Juzgado de Garantía de Santiago, con siete jueces, con competencia sobre las comunas de San Ramón y La Pintana." & @CRLF & _
"" & @CRLF & _
"Región de Ñuble:" & @CRLF & _
"" & @CRLF & _
"San Carlos, con dos jueces, con competencia sobre las comunas de San Carlos, Ñiquén y San Fabián." & @CRLF & _
"" & @CRLF & _
"Chillán, con cuatro jueces, con competencia sobre las comunas de San Nicolás, Chillán, Coihueco, Pinto y Chillán Viejo." & @CRLF & _
"" & @CRLF & _
"Yungay, con un juez, con competencia sobre las comunas de El Carmen, Pemuco, Yungay y Tucapel."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")