import Foundation
let pattern = #"^(?P<CP>\d{4}[\-\ ]?\d{3})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#Valid:
1234567
1234 567
1234-567
#Invalid:
1234|567
1234:567
1234*567
1234/567
1234\567
1234 567
1234--567
1234||567
1234::567
1234**567
1234//567
1234\\567
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)