$re = '/^(?P<CP>\d{4}[\-\ ]?\d{3})$/m';
$str = '
#Valid:
1234567
1234 567
1234-567
#Invalid:
1234|567
1234:567
1234*567
1234/567
1234\\567
1234 567
1234--567
1234||567
1234::567
1234**567
1234//567
1234\\\\567
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);