const regex = new RegExp('(\\d{4}).(\\(.*?\\)).(?:\\(.*\\)).-.(\\d+\\.)?(\\d+\\.)?(\\d+\\.)?(\\*|\\d+)(?:.*?)(?:(\\w+).Edition)(?:.*?)(?:Windows.(\\w+.\\d+.\\w+))', 'gm')
const str = `Microsoft SQL Server 2012 (SP4-GDR) (KB4583465) - 11.0.7507.2 (X64) Nov 1 2020 00:48:37 Copyright (c) Microsoft Corporation Standard Edition (64-bit) on Windows NT 6.3 <X64> (Build 14393: ) (Hypervisor)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}