re = /^([pP]laza)\s?([A-Za-z ]{0,})\,?\s?(\d{0,}|s\/n)\,?\s?\d{0,}[ºª]?\s?[a-zA-Z]?$/m
str = 'calle prueba, 2
calle de la prueba, 5
Avenida de la prueba, 5
Plaza de la prueba, 5
Plaza Higuereta, 4, 7º B
Plaza Escritor Conde Zamora s/n
Avenida Ciudad de Aranjuez 18
Plaza Pintor Sorolla 125 4ºG
Polígono Industrial Aranguren 6
Plaza Gremi Passamaners 24 2º
Avenida Manuel Rodriguez Ayuso, 170
Plaza Illa de Buda 55
Plaza Walia, 21
C/Alfonso Pesquera, 6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end