#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([pP]laza)\s?([A-Za-z ]{0,})\,?\s?(\d{0,}|s\/n)\,?\s?\d{0,}[ºª]?\s?[a-zA-Z]?$"
Local $sString = "calle prueba, 2" & @CRLF & _
"calle de la prueba, 5" & @CRLF & _
"Avenida de la prueba, 5" & @CRLF & _
"Plaza de la prueba, 5" & @CRLF & _
"Plaza Higuereta, 4, 7º B" & @CRLF & _
"Plaza Escritor Conde Zamora s/n" & @CRLF & _
"Avenida Ciudad de Aranjuez 18" & @CRLF & _
"Plaza Pintor Sorolla 125 4ºG" & @CRLF & _
"Polígono Industrial Aranguren 6" & @CRLF & _
"Plaza Gremi Passamaners 24 2º" & @CRLF & _
"Avenida Manuel Rodriguez Ayuso, 170" & @CRLF & _
"Plaza Illa de Buda 55" & @CRLF & _
"Plaza Walia, 21" & @CRLF & _
"C/Alfonso Pesquera, 6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")