import Foundation
let pattern = #"(["])(?:(?!\1|"").|"".)*\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello Colm "This is a test""\\"
"This is also an NL test"
'And this has an escaped quote don\'t in it ' Blue Boy
"This has a single quote ' but doesn\' end the quote as it started with double quotes"
"""line spanning with escaped quote at the end of a line"""
""""
"Foo Bar" "Another Value" something else
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Subbed"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)