$re = '/^([0-9]{1,3}( )?){1,}( )?(€|\$)$/m';
$str = '123 213213231€
120000000€';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);