package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{1,3}( )?){1,}( )?(€|\$)$`)
var str = `123 213213231€
120000000€`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}