re = /^(0098|\+98|98|0|)(9\d{9}$)/m
str = '00989123456789
+989123456789
989123456789
09123456789
9123456789
321351321321
+98913131532
sad00989123456789
00989123456789abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end