#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0098|\+98|98|0|)(9\d{9}$)"
Local $sString = "00989123456789" & @CRLF & _
"+989123456789" & @CRLF & _
"989123456789" & @CRLF & _
"09123456789" & @CRLF & _
"9123456789" & @CRLF & _
"321351321321" & @CRLF & _
"+98913131532" & @CRLF & _
"sad00989123456789" & @CRLF & _
"00989123456789abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")